APLawrence.com -  Resources for Unix and Linux Systems, Bloggers and the self-employed

FTP Problem


Some material is very old and may be incorrect today

© April 2008 Josh
Josh

Hello - I'm having a problem with a server running SCO OpenServer 5.0.7 and ftp. ftp connections used to work fine, but now I can connect to the server via ftp, I can issue type, pwd, and cd commands successfully and receive the response-- but when I issue ls, dir, get, or put commands, I get the message: "425 Can't build data connection: Invalid argument." No file configuration changes were made. The server was moved and is behind a new firewall, but as I said, I can connect and issue some commands successfully. Port 21 is open on the firewall so I can connect.

From the server, I can ftp to other sites and all commands work.

I do suspect the firewall, but I don't know why some commands work and others dont.


If you found something useful today, please consider a small donation.



Got something to add? Send me email.





(OLDER)    <- More Stuff -> (NEWER)    (NEWEST)   

Printer Friendly Version

->
-> ftp through firewall

10 comments


Inexpensive and informative Apple related e-books:

iOS 8: A Take Control Crash Course

Take Control of Apple Mail, Third Edition

Take Control of OS X Server

Take Control of iCloud

Take Control of Pages





More Articles by © Josh







Thu Apr 17 17:37:55 2008: 4049   TonyLawrence

gravatar
Yes, Josh, it is the firewall, and to understand why you need to read up on how ftp actually works - what you want is to have it work in "passive" mode.

I thought I had an article here somewhere that explained this well, but can't seem to find it.. I'll look a bit more..



Thu Apr 17 19:22:37 2008: 4052   Josh


Thanks Tony.
I did try to get passive mode to work before I wrote, but the connection disconnects at the server when switching to PASV mode. Perhaps there is a config entry I'm missing?
Josh






Thu Apr 17 19:30:41 2008: 4053   TonyLawrence

gravatar
Perhaps the server can't do passive mode?



Thu Apr 17 21:06:28 2008: 4054   BruceGarlock


Doesn't port 20 need to be open at the firewall as well (ftp-data).



Fri Apr 18 01:55:11 2008: 4056   Josh


I can ftp Active and Passive behind the firewall. Since neither Active nor Passive is working on the public side, it must be a firewall issue...an odd one to be sure, but a firewall issue nonetheless.
Port 20 and 21 are both open on the firewall.
I have a local Cisco engineer looking at it.
Thanks for your comments- both of you-- you helped me narrow this down very quickly.

Josh



Fri Apr 18 02:16:32 2008: 4058   TonyLawrence

gravatar
Ayup - firewall is blocking you for sure.. strange symptoms though.



Tue Oct 4 17:31:23 2011: 9902   anonymous

gravatar


I am having the same problem but I am not understanding what was done to make this problem go away?



Tue Oct 4 17:46:49 2011: 9903   TonyLawrence

gravatar


I don't know. Unfortunately, Josh never returned to update us.



Fri Oct 7 15:52:06 2011: 9939   anonymous

gravatar


Great. Now I have guilt!
--
I don't have my notes from that time handy, but I believe that the problem was related to Active vs. Passive FTP. I'll update again as soon as I can review my notes.



Fri Oct 7 16:01:49 2011: 9940   TonyLawrence

gravatar


But at the time you said you had tried Passive, so perhaps there was more to it.

Don't feel too guilty :-)

If you can find it, great. If not, we'll survive.

------------------------


Printer Friendly Version

Have you tried Searching this site?

This is a Unix/Linux resource website. It contains technical articles about Unix, Linux and general computing related subjects, opinion, news, help files, how-to's, tutorials and more.

Contact us


Printer Friendly Version





Unlike info, pinfo does not display anything if it has nothing. I've been forever irritated by info coming up with its default page when it has nothing to tell me. (Tony Lawrence)




Linux posts

Troubleshooting posts


This post tagged:

FTP

Forum

Networking

SCO_OSR5



Unix/Linux Consultants

Skills Tests

Unix/Linux Book Reviews

My Unix/Linux Troubleshooting Book

This site runs on Linode