# # CPIO error 27 - File too large
APLawrence.com -  Resources for Unix and Linux Systems, Bloggers and the self-employed

CPIO error 27 - File too large

I've removed advertising from most of this site and will eventually clean up the few pages where it remains.

While not terribly expensive to maintain, this does cost me something. If I don't get enough donations to cover that expense, I will be shutting the site down in early 2020.

If you found something useful today, please consider a small donation.



Some material is very old and may be incorrect today

© February 2006 anonymous


Author: anonymous
Date: Tue Feb 21 10:26:28 2006
Subject: CPIO error 27 - File too large

When I do a backup "find / -o -print | cpio -ocv -O /file_system_in_AIX" in a NFS mounted on AIX system appears the error:


cpio: I/O error on write() : File too large (error 27)

The AIX file System is created for big files

As I can solve it?

SCO OpenServer 5.0.6



If you found something useful today, please consider a small donation.



Got something to add? Send me email.





(OLDER)    <- More Stuff -> (NEWER)    (NEWEST)   

Printer Friendly Version

->
-> CPIO error 27 - File too large

4 comments


Inexpensive and informative Apple related e-books:

Photos for Mac: A Take Control Crash Course

Digital Sharing Crash Course

Take Control of Parallels Desktop 12

Take Control of Preview

Take Control of High Sierra





More Articles by © anonymous







Tue Feb 21 11:22:52 2006: 1679   TonyLawrence

gravatar
NFS isn't AIX. You have a (N)etwork (F)ile (S)ystem that happens to have an AIX file system under it.

NFS V2 only supports up to 2GB. NFS V3 supports more.

SCO 5.0.6 uses V2, Openserver 6 uses V3. I have no idea what your AIX uses, and I don't know what happens when a V2 client mounts a V3 server. However, the answer is going to be on the AIX side, not on the SCO, because 5.0.6 only has V2.

I did find this from (link)

 
The file size limit for files located on an NFS server is taken from the process environment when nfsd is started. To use a specific value, edit the file /etc/rc.nfs and add a ulimit, using the ulimit command, with the desired limit before the startsrc command for nfsd.


but again I'm unclear on exactly how NFS V3 interacts with V2.







Tue Feb 21 12:10:01 2006: 1683   TonyLawrence

gravatar
Oh, and of course cpio itself is running on OSR5.0.6 so it may be IT that can't handle the offset - in fact, that's probably the issue.



Tue Feb 21 22:58:11 2006: 1689   dhart


I seem to recall that last time I tried this (1988?) the problem with moving cpio *tapes* between systems was the little endian/big endian problem. There was a switch in AIX's cpio that let me make a tape that could be read on ATT a SVR4 system (50MHz 486 IIRC).



Thu Feb 23 08:21:41 2006: 1698   anonymous


In my case, the applied solution is:
cd /
tar cvf - . | rcmd address_of_remote_system "dd of=remote_device"

The speed is very, very best and no have the problem 'file too large'

------------------------


Printer Friendly Version

Have you tried Searching this site?

This is a Unix/Linux resource website. It contains technical articles about Unix, Linux and general computing related subjects, opinion, news, help files, how-to's, tutorials and more.

Contact us


Printer Friendly Version





FORTRAN was the language of choice for the same reason that three-legged races are popular. (Ken Thompson)




Linux posts

Troubleshooting posts


This post tagged:

Forum



Unix/Linux Consultants

Skills Tests

Unix/Linux Book Reviews

My Unix/Linux Troubleshooting Book

This site runs on Linode