# # Print copies problem
APLawrence.com -  Resources for Unix and Linux Systems, Bloggers and the self-employed

Print copies problem

I've removed advertising from most of this site and will eventually clean up the few pages where it remains.

While not terribly expensive to maintain, this does cost me something. If I don't get enough donations to cover that expense, I will be shutting the site down in early 2020.

If you found something useful today, please consider a small donation.



Some material is very old and may be incorrect today

© August 2005 anonymous


Author: anonymous
Date: Fri Aug 26 10:58:06 2005
Subject: Print copies problem

When attempt to remote print several copies of a document with the command 'lp -n2 -d printer file', leaves printed one copies. as it can be the problem? as I can see if SCO is really sending a copy or two to the printer?

System = SCO_SV
Release = 3.2v5.0.6
Print Server = Lexmark MarkNet

If you found something useful today, please consider a small donation.



Got something to add? Send me email.





(OLDER)    <- More Stuff -> (NEWER)    (NEWEST)   

Printer Friendly Version

->
-> Print copies problem

4 comments


Inexpensive and informative Apple related e-books:

iOS 10: A Take Control Crash Course

Take control of Apple TV, Second Edition

Take Control of iCloud

El Capitan: A Take Control Crash Course

Photos for Mac: A Take Control Crash Course





More Articles by © anonymous







Fri Aug 26 15:20:14 2005: 1031   TonyLawrence

gravatar
OK, but the answer is still the same:

Printing is all controlled by interface scripts, which you can read all about at (link)

Examine your script and see why it is not printing. It's probably not even looking at $4 (copies). Or you are trying to send that to some remote lpd printer that doesn't understand or care.






Mon Aug 29 10:27:39 2005: 1036   anonymous


I feel it, but I cannot find script to modify.

In order to register the printer I make the following:
scoadmin printer manager
Printer --> Add remote --> UNIX
Deselect the Extended remote printing protocol
See (link)

After I verify if script has creates some in /usr/spool/lp/admins/lp/interfaces or /var/spool/lp/admins/lp/interfaces and does not exist any file with the name of the printer.

Files:
$ cat /usr/spool/lp/admins/lp/printers/PRT9400_0/configuration
Banner:
Device: [email protected]
Interface:
Printer type:
Remote: [email protected]


$ cat /etc/printcap
PRT9400_0:\
:lp=imp94006:ex:sd=/usr/spool/lpd/PRT9400_0:mx#0:of=/usr/bin/lp_addcrff:


Greetings,






Mon Aug 29 11:11:42 2005: 1037   TonyLawrence

gravatar
You are printing to a remote printer. As already noted, that's where the problem is: either your end isn't passing the args or the other end doesn't care.

One way to handle that is to "front-end" with a virtual printer that sends the job to the real printer as many times as requested in $4. There are examples of virtual printers at (link) and a search here for "virtual printer" will turn up other examples.



Wed Aug 31 12:29:17 2005: 1048   anonymous


Solved problem.
I have created a local printer (model:network and device:/dev/null) and later I have associated it in the file /usr/spool/lp/remote with the remote printer.
The remote printer has a filter that adds CR-LF and FF, as well as the escape sequences that need to us.

Thank you very much by the aid

------------------------


Printer Friendly Version

Have you tried Searching this site?

This is a Unix/Linux resource website. It contains technical articles about Unix, Linux and general computing related subjects, opinion, news, help files, how-to's, tutorials and more.

Contact us


Printer Friendly Version





Tough times never last, but tough people do. (Robert H. Schuller)




Linux posts

Troubleshooting posts


This post tagged:

Forum

Networking

Printing

Troubleshooting



Unix/Linux Consultants

Skills Tests

Unix/Linux Book Reviews

My Unix/Linux Troubleshooting Book

This site runs on Linode