APLawrence.com -  Resources for Unix and Linux Systems, Bloggers and the self-employed

ScoUnix Portmapping issue

© March 2005 anonymous

Author: anonymous
Date: Wed Mar 9 16:25:37 2005
Subject: ScoUnix Portmapping issue

I recently moved this network over to a new office and one of the machines was a sco Unix box using SCO OpenServer 5.0.6. Now when I boot it up it hangs for awhile at the bringing up interface tty02.. please wait screen. Then after like 5 minutes I start getting portmapping errors. It appears to try to connect to an ip address that apparently is not there. It shows the error 3 times and just sits there.

Is there a way around this? I cant seem to find the computer it is looking for. It could be portmapping to itself. I dunno how to get the ip address because I cant get to the command line. Please help!

Got something to add? Send me email.

(OLDER)    <- More Stuff -> (NEWER)    (NEWEST)   

Printer Friendly Version

-> ScoUnix Portmapping issue


Inexpensive and informative Apple related e-books:

Take Control of Apple Mail, Third Edition

iOS 8: A Take Control Crash Course

Take Control of Automating Your Mac

Are Your Bits Flipped?

Take Control of OS X Server

More Articles by © anonymous

Wed Mar 9 16:35:22 2005: 121   TonyLawrence

That's usually an incorrect or duplicate ip in /etc/hosts. See (link)

Wed Mar 9 16:47:54 2005: 122   anonymous

Thank you for the response, I read that but how do I access anything? It just hangs at that screen. I cant get to the command line to look/change the ip. The ips should be the same btw. But in either case how do I bypass this screen and go straight to the command line so I can figure out what ip it has?

Wed Mar 9 16:48:41 2005: 123   TonyLawrence

If you can't switch screens (ctrl-alt-f3) then your init scripts are hung -

Wed Mar 9 16:51:50 2005: 124   anonymous

Where do I hit that at? At the screen where the portmapper is erroring out? The system boots up correctly but the screen right before the login shows this:

scologin bringing up /dev/tty02. Please wait.... portmapper is not responding portmapper is not responding portmapper is not responding

It just shows that and does nothing else. So I should be able to hit the keys you mentioned and it should switch if the init is not hung?


Wed Mar 9 16:52:27 2005: 125   TonyLawrence

If you are hanging, you need to find out where. Stop in single user mode, and look in /etc/rc2.d/messages - see what the last script to run was, trace the problem from there.

Wed Mar 9 16:54:33 2005: 126   TonyLawrence

If that really says "bringing up /dev/tty02" your network config is really screwed up.

Try ctrl-alt-f3 then, or stop at single user. You have something WAY out of whaxck here..

Wed Mar 9 16:57:20 2005: 127   anonymous

Well it always says that. I did a test reboot before bringing it down and moving to new location. That screen came up but it didnt error out, it would then proceed onto the SCO login. Single user mode? Hmm.. How do I bring up the single user mode? sorry for sounding stupid, just not used to SCO Unix

Wed Mar 9 17:07:14 2005: 128   anonymous

I assume single user mode is system maintenance?

Wed Mar 9 17:08:05 2005: 129   TonyLawrence

At the Boot: prompt press enter rather then letting it time ot. When it stops at the Ctrl-D prompt, enter the root password.

Wed Mar 9 17:13:37 2005: 130   anonymous

Thank you for your help. Im really worried though as we did not change anything on the SCO box and all we did was pick up the network as it was and put in new office as it was. The system is on a old Dell PowerEdge with dual nics if that helps at all.

Why is it trying to bring up /dev/tty02? I noticed the processes running when it was working in last office showed tty02 through tty05. Are these specific to modems at all? It has 5 modems connected to a Digi box which then connects to the SCO box.

Wed Mar 9 17:26:03 2005: 131   TonyLawrence


tty01 - tty12 are the virtual consoles. You may only have through 05 enabled. 02 is X if enabled.

Sounds to me like you need a local consultant. I don't think (link) is going to bring you up to speed quickly enough. See (link)

Wed Mar 9 17:27:23 2005: 132   anonymous

What looks like spam? You want to email me? I live in Arizona and only asking for help.

Wed Mar 9 17:29:16 2005: 133   TonyLawrence

No, sorry :-) Got trapped by my own spam checkers - forgot to preview and had too many links..

Wed Mar 9 17:38:29 2005: 134   anonymous

No problem :) I dont think anything needs to be changed though, which worries me as we didnt change anything at all. I just hope I can at least get in to see the logs. If not then will have to outsource this one

Wed Mar 9 17:55:54 2005: 135   anonymous

BTW I also noticed it complains about single user license for SCO at bootup. But I assume that wouldnt have affect on the issue at hand?

Wed Mar 9 18:06:11 2005: 136   TonyLawrence

If you think this should be an ordinarily licensed system, then yes, it may indicate even more problems.

Did you install this or someone else?

Wed Mar 9 19:13:34 2005: 137   anonymous

This SCO box was at this company 10 years. This is the first time Im touching it. I tried what you mentioned to switch virtual consoles, it worked. I can get into tty03 just fine. Some problems I saw. When I logged into tty03 I tried to ping outside, it hung for awhile and then gave me this error:

Login Error: Failed to initialize License Policy Manager (IFor.pm_fatal) Serious condition has occured. Only single user login allowed.

I rebooted the system and the error about licensing I mentioned in earlier post stated the root filesystem appears to be read only or program image damaged.

The portmapping error I found out is trying to portmap to itself on a different NIC. So I guess the second NIC is not responding for some reason. This is all a mouth full and would appreciate if you can point me in direction on this issue

Thank you

Wed Mar 9 19:54:11 2005: 138   TonyLawrence

You might want to try using the Search box: searching for "Policy Manager" turns up relevant material instantly

(link) is probably what you need.

Wed Mar 9 20:05:48 2005: 139   anonymous

I did that, but majority of solutions give GUI instructions. I dont have GUI access. Unless Im missing something.

Wed Mar 9 20:21:08 2005: 140   anonymous

This is what is exactly happening at bootup:


But the fact that it still goes on and boots makes me feel it isnt an issue or at least not the issue causing this problem. Right now the issue is it hangs when trying to bring up virtual console 2 and gives portmapper error which as you pointed out could be due to network changes. The only change is physical location though.

Wed Mar 9 20:25:00 2005: 141   TonyLawrence

Huh? No gui in that link.. I'm not sure what you saw, but it's command line stuff..

Anyway - something has gone very wrong here if it was just moved as described. Could it have been damaged in transit?

Wed Mar 9 20:28:59 2005: 142   anonymous

I moved the server myself and we took very good care in moving. We even wrapped it in bubble wrap. The system is extremely old and extremely dusted inside with very old equipment. The instructions on the link states things like:

In the Software Manager, choose Software->Verify Software ->Broken/missing symbolic links

Sounds like you need a GUI to get there. Again though I may be wrong. In either case if it was damaged in transit then it was going to happen soon anyway because we took every precaution. I mean their whole friggin business runs on this thing. That in itself is another story.

Wed Mar 9 20:30:25 2005: 143   TonyLawrence

No, you don't need a gui. Just type


It'a all there..

Wed Mar 9 20:33:50 2005: 144   anonymous

Geez Im a moron. Thanks again. Its tough to search for this on google due to the fact I do not know what to look for. I type in sco unix or unix sco and get unrelated stuff to this issue. I type in the errors I get and nothing comes up relevant

Wed Mar 9 20:47:41 2005: 145   TonyLawrence

Use the search here.. and if you don't find what you want, make post..

Wed Mar 9 22:50:25 2005: 146   TonyLawrence

(link) covers issues of not getting a login at the console in addition to the the other problems discussed there.

What usually happens is that something in /etc/rc2 never finishes. Inittab has a "wait" tag for rc2, so init waits for it to finish before going on to things like the gettys. Usually this is after tcp has started, so you probably CAN telnet to the box even if you can't log in at the console.

But this system sounds very broken.. be careful with custom verifying permissions - I suggest looking at what it wants to do very carefully before letting it proceed.

Let us know how you make out..

Thu Mar 10 14:58:06 2005: 151   anonymous

Well still no luck. I can get to the other virtual consoles just fine, but tty92 hangs. Also the port mapping issue is weird. It still fails trying to look for the other nic on its system, but the ips are visible on the network.

Meaning if I tried to change another system to the same ip as the SCO box I get ip already registered on the network. I disconnect it then I can use the ips just fine. Yet they cant see each other. I think its because the ip they are using are legit external ips. They are using and .67 which is a school in Utah, but some past admin used it for internal ips.

I tried just hooking both up to its own hub so that it can only see each other, same issue except this time they werent passing any traffic to on the hub, extremely strange. I think it is trying to go out of the network to find it. Which leads to believe a gateway issue?

I ran scoadmin and did symlink checks and everything was fine. I also went to Licensing Manager and it shows 4 licenses, one of them said 25 user license. All of them show status of expired.

This is why I cant start the licensing manager, /etec/ifor_pmd, because the licenses have expired. I didnt delete the license cause I dont know if that would do anything, especially since they have no records of their licenses.

But licensing issue shouldnt cause portmapping issue could it? I did notice that when it was at the bringing up /dev/tty02 screen I switched to tty01 which showed bootup status. I noticed it said couldnt start tcp ip_out due to licensing issues? Could that be a cause for anything? Also notice IPX failed to start, but dunno if that was normal before. It also times out trying to run some script, stating 120 seconds have passed and cannot start udp services?

I put that box back to the original status and still the issues above are happening, I used same exact cables plugged into the same exact NICS and the same exact switch ports. Any suggestions?

Thu Mar 10 15:18:39 2005: 152   anonymous

Oh and I also tried the fsck command you gave in one of your articles you forwarded me to. It found some issues and fixed and remounted the root drive. (It said that anyway) So after that still same issue. Also tty02 not tty92 as stated in my last post.

I cant for the life of me figure out why this wont work. Nothing changed, its using the same setup as the last office. Just dont get it.

Thu Mar 10 15:55:19 2005: 155   anonymous

Thanks, if this isnt the place then please point me in the right direction. I was actually waiting for some input by Lawrence then go get a SCO expert to come out and take a look.

Thu Mar 10 16:09:40 2005: 156   anonymous

Ok called one of the AZ guys listed on here for SCO. thanks everyone for the help. At least I know more about SCO.

Thu Mar 10 17:46:28 2005: 158   anonymous

One thing to add to all these comments & replies:

Unless you're a frequent user of X Windows at the system console on OpenServer 5.0.x, it's usually best to disable the scologin that starts automatically at boot on tty02. Logged in as root, or in single-user mode, type:

scologin disable

tty02 will now be just another console screen to login on.
If you need an X Windows session, just type in:


at any console shell prompt.

This eliminates the "Waiting for tty02..." message during startup, and prevents unexpected hangs because you've made an innocuous hardware change such as changing a defective video card or monitor.


Thu Mar 10 17:59:00 2005: 159   anonymous

Thanks for the input. The problem though is why it is hanging and why the network on this box doesnt work. But will find out today as I called a SCO expert to come out. Heck I cant even ping localhost, drops all the packages. Definetly something wrong with network, pinging locally like that shows hardware problem or network config problem for sure

Thu Mar 10 22:36:24 2005: 162   TonyLawrence

Symptoms may indicate loss of cmos date..

Consistent with being moved, possibly..

Fri Mar 11 02:47:05 2005: 165   anonymous

The SCO guy came out and took a look. Apparently according to him he hadnt seen this before but the License for the SCO OS expired. So he had a contact at SCO and got the license registered to this company. Deleted license, reentered and now everything works. Geez was so friggin simple.

Thanks again for all your help!


Printer Friendly Version

Have you tried Searching this site?

This is a Unix/Linux resource website. It contains technical articles about Unix, Linux and general computing related subjects, opinion, news, help files, how-to's, tutorials and more.

Contact us

Printer Friendly Version

Never let a computer know you're in a hurry. (Anonymous)

Linux posts

Troubleshooting posts

This post tagged:


Unix/Linux Consultants

Skills Tests

Unix/Linux Book Reviews

My Unix/Linux Troubleshooting Book

This site runs on Linode