# # Strange Terminal Emulation Problem
APLawrence.com -  Resources for Unix and Linux Systems, Bloggers and the self-employed

Strange Terminal Emulation Problem

I've removed advertising from most of this site and will eventually clean up the few pages where it remains.

While not terribly expensive to maintain, this does cost me something. If I don't get enough donations to cover that expense, I will be shutting the site down in early 2020.

If you found something useful today, please consider a small donation.



Some material is very old and may be incorrect today

© February 2005 Tony Lawrence


Author: TonyLawrence
Date: Sat Feb 19 16:28:35 2005
Subject: Strange Terminal Emulation Problem

I had a strange one the other day. Using Alphacom over a serial line to a SCO machine and the only way it would work was if the emulation was VT100.

Details: I could attach an old Wyse60 terminal to the same line and it worked fine no matter what emulation was chosen. With the PC, however, even changing emulation after logging in, with or without a tset, would send the screen insane - looked to me like the baud rate had suddenly changed. I found that I could still type commands, and doing an stty -a redirected to some file showed that nothing had changed on the Unix side (as expected). I was blaming a bad download of Alphacom, but then I tried regular old Windows Hyperterminal; this looked like it was having communication trouble: dropping characters, some characters set to high bit, etc. I cut the wiring to its basics (2,3,7) but no change.

So my assumption was and is a bad serial card - but why would vt100 work? I could even do long ls -lR's without a glitch.. this has me puzzled.


If you found something useful today, please consider a small donation.



Got something to add? Send me email.





(OLDER)    <- More Stuff -> (NEWER)    (NEWEST)   

Printer Friendly Version

->
-> Strange Terminal Emulation Problem

5 comments


Inexpensive and informative Apple related e-books:

Take Control of High Sierra

Take Control of iCloud, Fifth Edition

iOS 10: A Take Control Crash Course

Take Control of Preview

Take Control of Automating Your Mac





More Articles by © Tony Lawrence







Sat Feb 19 18:09:11 2005: 47   TonyLawrence

gravatar
Fortunately, vt100 was sufficient for the app that needed to be run here.





Mon Feb 21 16:03:35 2005: 53   BigDumbDinosaur


Maybe the serial card drivers are somehow mangling the non-VT100 escape sequences. Since every VT100 escape sequence begins with a CSI ($1B $5B or <ESC> [), it's possible the card drivers expect to see the left bracket as the next char after <ESC> and consider anything else to be bogus.



Mon Feb 21 16:28:04 2005: 54   TonyLawrence

gravatar
OK, but what business does a serial card driver have looking at escape sequences?







Mon Feb 21 18:27:41 2005: 55   anonymous


I'd suspect the *unnamed* serial card driver also. You could prove this by connecting to the standard COM1 or COM2 ports and seeing if you can replicate the problem. Perhaps the flow control is set to something non-standard like PC-TERM or hardware (DTR) flow control, and is being mangled by the driver.

I don't understand your remark that you could plug in a Wyse 60 terminal and have it work no matter what the emulation was set to. Are you referring to the emulation the terminal itself is setup to, along with a corresponding change to the TERM in the shell session? Or are you saying that if the terminal is using native wyse60 emulation, you could set the TERM environment variable to anything you'd like and it would still work?

It's also possible you've stumbed upon a minor Alphacom bug. Make sure you're using the latest build of version 5 or version 6.

--Bob



Mon Feb 21 19:24:48 2005: 56   TonyLawrence

gravatar
I meant, of course, that I could set the dumb terminal to any of its possibilities, and make the corresponding TERM change at the host, and all worked as expected - in other words, its not the wire or the digi or the host.

My suspecion is that the machine itself is whacked. I did try com1 also, with the noted result - partially garbled characters. Not as bad as on the PCI serial card, but bad stuff. I also used Hyperterm with the same problems, so it's not Alphacom either. Very, very puzzling..





------------------------


Printer Friendly Version

Have you tried Searching this site?

This is a Unix/Linux resource website. It contains technical articles about Unix, Linux and general computing related subjects, opinion, news, help files, how-to's, tutorials and more.

Contact us


Printer Friendly Version





C is quirky, flawed, and an enormous success. (Dennis Ritchie)




Linux posts

Troubleshooting posts


This post tagged:

Emulators

Forum

Serial



Unix/Linux Consultants

Skills Tests

Unix/Linux Book Reviews

My Unix/Linux Troubleshooting Book

This site runs on Linode