# # VNC on SCO
APLawrence.com -  Resources for Unix and Linux Systems, Bloggers and the self-employed

VNC on SCO

I've removed advertising from most of this site and will eventually clean up the few pages where it remains.

While not terribly expensive to maintain, this does cost me something. If I don't get enough donations to cover that expense, I will be shutting the site down in early 2020.

If you found something useful today, please consider a small donation.



Some material is very old and may be incorrect today

© August 2005 MikeHutchins


Author: MikeHutchins
Subject: VNC on SCO

I am trying to get VNC running on SCO I've tried everything listed here but no luck so far. I am getting a "vncserver: not found" when trying to start the server. I've checked paths and permissions and all looks ok.

gzcat did not seem to run correctly, it did not copy the files to the various directories. I had to copy them manually.

Any help?

Thanks Mike


If you found something useful today, please consider a small donation.



Got something to add? Send me email.





(OLDER)    <- More Stuff -> (NEWER)    (NEWEST)   

Printer Friendly Version

->
-> VNC on SCO

8 comments


Inexpensive and informative Apple related e-books:

Take Control of High Sierra

Take Control of Parallels Desktop 12

Take Control of OS X Server

Take Control of Apple Mail, Third Edition

iOS 10: A Take Control Crash Course





More Articles by © MikeHutchins







Wed Aug 10 18:33:33 2005: 954   TonyLawrence

gravatar
Did you read (link) ?







Wed Aug 10 19:39:25 2005: 955   MikeHutchins


I had'nt seen that one yet. I ran through it all and everything worked great.

Now it is trying to start and get's the error ~/.vnc: No such file or directory after asking to set the password.



Wed Aug 10 19:57:14 2005: 957   TonyLawrence

gravatar
OK, but next time please SEARCH the site for relevant articles before you post.

So, do you in fact have a /.vnc and if so, is it a symlink pointing somewhere non-existent?

This is another case where you should search before asking a question. If you searched for "no such file", you would have found (link) which might give you a clue as to the kinds of things that can cause that message. That search also would have brought up this text:

"You can see a file plainly in a listing but you can't copy it etc.- it says "no such file"- that's probably a symbolic link and the thing it points to is missing. Do "ls -l" to see the link. Or, it could be there are spaces or other control characters you don't see: try "ls -b" or redirect ls to a file and vi the file. A ":l" on a line will show you control characters, etc."

If you can't find what you want, or don't understand it, of course post - but please try to help yourself first.






Wed Aug 10 21:43:01 2005: 958   MikeHutchins


Sorry I did a search for "VNC and SCO", not Openserver, only 2 articles came up. Beleive me I like to work it out on my own most of the time but I am still a novice at unix and end up banging my head against the wall for a while sometimes.



Yes the /.vnc does exist and it's not a link. I was able to use vncpasswd to set the password and now it says it's running, but can't connect to it. I'll look around for a while.






Wed Aug 10 21:50:01 2005: 959   TonyLawrence

gravatar
Huh? I just searched "vnc and sco" and got

* 99.9 VNC on Sco Open Server by Ted Summers VNC on Sco Open Server *** vnc ***

* 99.9 Unixart/vnc_sco_openserver.html VNC on Sco Open Server
* 91.3 Blog/posts.html
* 77.8 Bofcusm/1484.html VNC
* 69.7 Bofcusm/790.html Re VNC SERVEUR
* 68.3 OSR5/smithosr5vmware.html Install SCO OpenServer under VMware Workstation
* 67.5 News/sconews0363.html
* 55.5 Bofcusm/2350.html Re Xwindows Server
* 55.5 Bofcusm/1127.html Re X Windows
* 39.2 Reviews/dhnetworkview.html Cool Tools: Network View - a network node discovery tool
* 39.2 Bofcusm/1513.html Re Visionfs Prining to USB HP1000 attached and shared on Win98
* 19.2 Bofcusm/949.html Re telnet ports

And the very first of those is the one you said you hadn't read.. so ???

Anyway, you are searching incorrectly.

Always start with ONE word - in this case, "vnc". If that gives you more than you want, add more to refine it. But always, always, always start with one word.



Wed Aug 10 21:57:42 2005: 960   TonyLawrence

gravatar
BTW, I understand the "head banging". Computer stuff can be very, very frustrating.



Fri Aug 12 01:40:24 2005: 966   MikeHutchins


Just an update. It's working!
After some confusion between :port and :display, and the console, I finally got it working. (Head banging included) I could start vncserver on :1 but could not connect or stop it completely. It would say it was already running on :1 when I started it. I am assuming now that is where the X on the console is. (Showing my ignorance of Unix).

I found the vncservers file and edited it to use :2 and there it was! Cool.

Next step is to start multiple servers for multiple users. Probably just 2. It looks like it is done in the vncservers as well, but I could be wrong.

Thanks for the help!

MH



Mon Aug 15 19:58:04 2005: 973   MikeHutchins


I ran across this site and it worked great.

(link)

I added this to the Xservers file.

:2 local /usr/local/bin/Xvnc :2 -httpd /usr/local/vnc/classes -geometry 1024x768 -rfbwait 120000 -rfbauth /.vnc/passwd -rfbport 5902 -alwaysshared




------------------------


Printer Friendly Version

Have you tried Searching this site?

This is a Unix/Linux resource website. It contains technical articles about Unix, Linux and general computing related subjects, opinion, news, help files, how-to's, tutorials and more.

Contact us


Printer Friendly Version





I think there is a world market for maybe five computers. (Thomas Watson, Chairman of IBM, 1943)




Linux posts

Troubleshooting posts


This post tagged:

Forum

Remote Access



Unix/Linux Consultants

Skills Tests

Unix/Linux Book Reviews

My Unix/Linux Troubleshooting Book

This site runs on Linode