Why doesn't rcp work for root?

Got questions? Go ahead: Ask me anything!

Anonymous asks:

Why doesn't rcp work for root? I get Permission Denied even though it works with other users?

Before I answer that, I'd like to first suggest that you forget about rcp and use scp. Unless the system you are using is too old to support ssh and scp, you really should not use rcp.

So my answers assume you cannot. The first thing to understand is that root has special rules. One is that you must use a .rhosts file in root's HOME directory. It must be owned by root and must be 0600 perms.

Be sure that root's HOME is where you think it is!

You also need to realize that any system names you put in .rhosts have to match what the system sees. Check by pinging the ip of the other site.

Another requirement is that root be allowed to login remotely. That may require an entry in /etc/securetty on some systems and you may also need to allow it in Selinux if that is enabled.

Obviously any firewalls in the way need to allow this and the rsh service has to be started or enabled in whatever functions as the super daemon on your system. As I'm assuming you are using something too old for ssh, that's probably /etc/inetd.conf or an /etc/xinetd.d file.



Got something to add? Send me email.





(OLDER) <- More Stuff -> (NEWER)    (NEWEST)   

Printer Friendly Version

-> -> Why doesn't rcp work for root?



Increase ad revenue 50-250% with Ezoic


More Articles by

Find me on Google+

© Anthony Lawrence



Kerio Samepage


Have you tried Searching this site?

Unix/Linux/Mac OS X support by phone, email or on-site: Support Rates

This is a Unix/Linux resource website. It contains technical articles about Unix, Linux and general computing related subjects, opinion, news, help files, how-to's, tutorials and more.

Contact us

privacy policy